import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[+·`\\-::]*?([\\u4e00-\\u9fa5]+)[+\\-十](\\d+([.::]\\d){0,2})(%|0/0|0\\|0|010)?";
final String string = "·暴击伤害+21.2%\n"
+ "·元素精通+11\n"
+ "暴击率+17.1%\n"
+ "+攻击力+20\n"
+ "·防御力+98\n"
+ "`防御力+21.7%\n"
+ "`生命值+2147\n"
+ "-攻击力+15.70/0\n"
+ "·暴击率+3:9%\n"
+ "防御力+31:0%\n"
+ "暴击伤害+46.6010";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}