re = /^|[a-zA-z]+\w*+[\/(]*+[0-9][0-9][)]*|^/m
str = 'gl23455/10
fhgg666(01)
BGL25MON8/04
0752200036(00)
SGI55M04EU/70
KSK38422FF/01
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end