const regex = /^|[a-zA-z]+\w*+[\/(]*+[0-9][0-9][)]*|^/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^|[a-zA-z]+\\w*+[\\\/(]*+[0-9][0-9][)]*|^', 'gm')
const str = `gl23455/10
fhgg666(01)
BGL25MON8/04
0752200036(00)
SGI55M04EU/70
KSK38422FF/01
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}