$re = '/^-{0,1}[0-9]*\.[0-9]+/';
$str = '-12.021
12.02
23.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);