package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^-{0,1}[0-9]*\.[0-9]+`)
var str = `-12.021
12.02
23.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}