import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?i)CHOC.*[.csv]$";
final String string = "CHOC_METRICS_2020-06-16.csv\n"
+ "Claims_PGSEO_20200110.txt\n"
+ "Claims_Agilon_20200110.txt\n"
+ "COPC_PE20190701_REHCF.TXT\n"
+ "Member_Agilon_PGSEO_Current_QualityRA_History_20200116.txt\n"
+ "Member_Agilon_PGSEO_Current_QualityRA_20200215.txt\n"
+ "Member_Agilon_PGSEO_Locked_Financial_20200115.txt\n"
+ "Member_Agilon_PGSEO_Locked_Financial_History_20200116.txt\n"
+ "Claims_PGSEO_History_20200116.txt\n"
+ "Member_Agilon_Current_QualityRA_20200215.txt\n"
+ "Member_Agilon_Locked_Financial_20191215.txt\n"
+ "COPC_ME_AETACOE6_201912_20200127.txt\n"
+ "SGPPN_PE20190701_REHCF.TXT\n"
+ "SGPPN_PE20200101_RECLMEXP.TXT\n"
+ "SGAGAKRN_PE20200301_RECLMEXP.TXT\n"
+ "PCMS_Inpatient_Admission_Patients_20190802100552.csv\n"
+ "PCMS_Inpatient_Admission_Patients_20190821154559.csv\n"
+ "Humana Dayton Census - Authorizations 4.30.20 Authorizations.csv\n"
+ "Humana Dayton Census - Authorizations 5.11.20.csv\n"
+ "Humana Dayton Census - Authorizations 4.30.20 Admits Discharges.csv\n"
+ "2020_05_04_Census.txt\n"
+ "2020_05_03_Discharges_Rolling7Days.txt\n"
+ "2020_05_04_Census.txt\n"
+ "2020_05_04_Discharges_Rolling7Days.txt\n"
+ "2019_12_21_Discharges_Rolling7Days.txt\n"
+ "2019_12_21_Census.txt\n"
+ "CHOC_RT_OutreachAttempt_20200502.csv\n"
+ "CHOC_RT_OutreachAttempt_20200509.csv\n"
+ "SGPPN_PE20200101_REMBX.TXT\n"
+ "PriMed_Phy_MAPPO_claim_det_02132020.txt\n"
+ "PriMed_Phy_MAPPO_claim_header_02132020.txt\n"
+ "PriMed_Phy_MAPPO_claim_header_proc_02132020.txt\n"
+ "PriMed_Phy_MAPPO_CLM_DIAG_02132020.txt\n"
+ "PriMed_Phy_MAPPO_member_02132020.txt\n"
+ "PriMed_Phy_MAPPO_member_eligibility_02132020.txt\n"
+ "OHCore_Care_Select_member_eligibility_01232020.txt\n"
+ "OHCore_Care_Select_member_eligibility_04152019.txt\n"
+ "OHCore_Care_Select_claim_det_07152019.txt\n"
+ "OHCore_Care_Select_claim_det_06182018.txt\n"
+ "OHCore_Care_Select_claim_det_01232020.txt\n"
+ "Pioneer_Phy_MAPPO_claim_det_02132020.txt\n"
+ "Pioneer_Phy_MAPPO_claim_header_02132020.txt\n"
+ "Pioneer_Phy_MAPPO_claim_header_proc_02132020.txt\n"
+ "Pioneer_Phy_MAPPO_CLM_DIAG_02132020.txt\n"
+ "Pioneer_Phy_MAPPO_member_02132020.txt\n"
+ "Pioneer_Phy_MAPPO_member_eligibility_02132020.txt\n"
+ "Physicians_Grp_Sohio_MAPPO_claim_det_02132020.txt\n"
+ "Physicians_Grp_Sohio_MAPPO_claim_header_02132020.txt\n"
+ "Physicians_Grp_Sohio_MAPPO_claim_header_proc_02132020.txt\n"
+ "Physicians_Grp_Sohio_MAPPO_CLM_DIAG_02132020.txt\n"
+ "Physicians_Grp_Sohio_MAPPO_member_02132020.txt\n"
+ "Physicians_Grp_Sohio_MAPPO_member_eligibility_02132020.txt\n"
+ "Central_Ohio_PC_MAPPO_claim_det_02132020.txt\n"
+ "Central_Ohio_PC_MAPPO_claim_header_02132020.txt\n"
+ "Central_Ohio_PC_MAPPO_CLM_DIAG_02132020.txt\n"
+ "Central_Ohio_PC_MAPPO_member_02132020.txt\n"
+ "Central_Ohio_PC_MAPPO_member_eligibility_02132020.txt\n"
+ "Central_Ohio_PC_MAPPO_claim_header_proc_02132020.txt\n"
+ "CORECARESELECT1OH_ENC_837P_20190927_529128\n"
+ "Copy of Pioneer_DailyAuth_SummaCare_20191227.csv\n"
+ "Copy of Pioneer_DailyAuth_SummaCare_20200329.csv\n"
+ "Copy of Pioneer_DailyAuth_SummaCare_20200414.csv\n"
+ "Copy of Pioneer_DailyAuth_SummaCare_20200402.csv\n"
+ "Pioneer_DailyAuth_SummaCare_20191227.csv\n"
+ "Pioneer_DailyAuth_SummaCare_20200329.csv\n"
+ "MG 11.22.19 HospitalListReport.csv\n"
+ "Humana COPC Census - Authorizations 3.26.20 Admits Discharges.csv\n"
+ "Humana COPC Census - Authorizations 13.6.20 Admits Discharges.csv\n"
+ "Humana COPC Census - Authorizations 3.26.20 Authorizations.csv\n"
+ "Humana COPC Census - Authorizations 11.01.20 Authorizations.csv\n"
+ "Humana COPC Census - Authorizations 2.2.20 Authorizations.csv\n"
+ "Humana Census - Admits Discharges 20200420.csv\n"
+ "^0420 file bad\n"
+ "Humana Census - Admits Discharges 20200416.csv\n"
+ "Humana Census - Authorizations 20200416.csv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}