#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?i)CHOC.*[.csv]$"
Local $sString = "CHOC_METRICS_2020-06-16.csv" & @CRLF & _
"Claims_PGSEO_20200110.txt" & @CRLF & _
"Claims_Agilon_20200110.txt" & @CRLF & _
"COPC_PE20190701_REHCF.TXT" & @CRLF & _
"Member_Agilon_PGSEO_Current_QualityRA_History_20200116.txt" & @CRLF & _
"Member_Agilon_PGSEO_Current_QualityRA_20200215.txt" & @CRLF & _
"Member_Agilon_PGSEO_Locked_Financial_20200115.txt" & @CRLF & _
"Member_Agilon_PGSEO_Locked_Financial_History_20200116.txt" & @CRLF & _
"Claims_PGSEO_History_20200116.txt" & @CRLF & _
"Member_Agilon_Current_QualityRA_20200215.txt" & @CRLF & _
"Member_Agilon_Locked_Financial_20191215.txt" & @CRLF & _
"COPC_ME_AETACOE6_201912_20200127.txt" & @CRLF & _
"SGPPN_PE20190701_REHCF.TXT" & @CRLF & _
"SGPPN_PE20200101_RECLMEXP.TXT" & @CRLF & _
"SGAGAKRN_PE20200301_RECLMEXP.TXT" & @CRLF & _
"PCMS_Inpatient_Admission_Patients_20190802100552.csv" & @CRLF & _
"PCMS_Inpatient_Admission_Patients_20190821154559.csv" & @CRLF & _
"Humana Dayton Census - Authorizations 4.30.20 Authorizations.csv" & @CRLF & _
"Humana Dayton Census - Authorizations 5.11.20.csv" & @CRLF & _
"Humana Dayton Census - Authorizations 4.30.20 Admits Discharges.csv" & @CRLF & _
"2020_05_04_Census.txt" & @CRLF & _
"2020_05_03_Discharges_Rolling7Days.txt" & @CRLF & _
"2020_05_04_Census.txt" & @CRLF & _
"2020_05_04_Discharges_Rolling7Days.txt" & @CRLF & _
"2019_12_21_Discharges_Rolling7Days.txt" & @CRLF & _
"2019_12_21_Census.txt" & @CRLF & _
"CHOC_RT_OutreachAttempt_20200502.csv" & @CRLF & _
"CHOC_RT_OutreachAttempt_20200509.csv" & @CRLF & _
"SGPPN_PE20200101_REMBX.TXT" & @CRLF & _
"PriMed_Phy_MAPPO_claim_det_02132020.txt" & @CRLF & _
"PriMed_Phy_MAPPO_claim_header_02132020.txt" & @CRLF & _
"PriMed_Phy_MAPPO_claim_header_proc_02132020.txt" & @CRLF & _
"PriMed_Phy_MAPPO_CLM_DIAG_02132020.txt" & @CRLF & _
"PriMed_Phy_MAPPO_member_02132020.txt" & @CRLF & _
"PriMed_Phy_MAPPO_member_eligibility_02132020.txt" & @CRLF & _
"OHCore_Care_Select_member_eligibility_01232020.txt" & @CRLF & _
"OHCore_Care_Select_member_eligibility_04152019.txt" & @CRLF & _
"OHCore_Care_Select_claim_det_07152019.txt" & @CRLF & _
"OHCore_Care_Select_claim_det_06182018.txt" & @CRLF & _
"OHCore_Care_Select_claim_det_01232020.txt" & @CRLF & _
"Pioneer_Phy_MAPPO_claim_det_02132020.txt" & @CRLF & _
"Pioneer_Phy_MAPPO_claim_header_02132020.txt" & @CRLF & _
"Pioneer_Phy_MAPPO_claim_header_proc_02132020.txt" & @CRLF & _
"Pioneer_Phy_MAPPO_CLM_DIAG_02132020.txt" & @CRLF & _
"Pioneer_Phy_MAPPO_member_02132020.txt" & @CRLF & _
"Pioneer_Phy_MAPPO_member_eligibility_02132020.txt" & @CRLF & _
"Physicians_Grp_Sohio_MAPPO_claim_det_02132020.txt" & @CRLF & _
"Physicians_Grp_Sohio_MAPPO_claim_header_02132020.txt" & @CRLF & _
"Physicians_Grp_Sohio_MAPPO_claim_header_proc_02132020.txt" & @CRLF & _
"Physicians_Grp_Sohio_MAPPO_CLM_DIAG_02132020.txt" & @CRLF & _
"Physicians_Grp_Sohio_MAPPO_member_02132020.txt" & @CRLF & _
"Physicians_Grp_Sohio_MAPPO_member_eligibility_02132020.txt" & @CRLF & _
"Central_Ohio_PC_MAPPO_claim_det_02132020.txt" & @CRLF & _
"Central_Ohio_PC_MAPPO_claim_header_02132020.txt" & @CRLF & _
"Central_Ohio_PC_MAPPO_CLM_DIAG_02132020.txt" & @CRLF & _
"Central_Ohio_PC_MAPPO_member_02132020.txt" & @CRLF & _
"Central_Ohio_PC_MAPPO_member_eligibility_02132020.txt" & @CRLF & _
"Central_Ohio_PC_MAPPO_claim_header_proc_02132020.txt" & @CRLF & _
"CORECARESELECT1OH_ENC_837P_20190927_529128" & @CRLF & _
"Copy of Pioneer_DailyAuth_SummaCare_20191227.csv" & @CRLF & _
"Copy of Pioneer_DailyAuth_SummaCare_20200329.csv" & @CRLF & _
"Copy of Pioneer_DailyAuth_SummaCare_20200414.csv" & @CRLF & _
"Copy of Pioneer_DailyAuth_SummaCare_20200402.csv" & @CRLF & _
"Pioneer_DailyAuth_SummaCare_20191227.csv" & @CRLF & _
"Pioneer_DailyAuth_SummaCare_20200329.csv" & @CRLF & _
"MG 11.22.19 HospitalListReport.csv" & @CRLF & _
"Humana COPC Census - Authorizations 3.26.20 Admits Discharges.csv" & @CRLF & _
"Humana COPC Census - Authorizations 13.6.20 Admits Discharges.csv" & @CRLF & _
"Humana COPC Census - Authorizations 3.26.20 Authorizations.csv" & @CRLF & _
"Humana COPC Census - Authorizations 11.01.20 Authorizations.csv" & @CRLF & _
"Humana COPC Census - Authorizations 2.2.20 Authorizations.csv" & @CRLF & _
"Humana Census - Admits Discharges 20200420.csv" & @CRLF & _
"^0420 file bad" & @CRLF & _
"Humana Census - Admits Discharges 20200416.csv" & @CRLF & _
"Humana Census - Authorizations 20200416.csv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")