// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?P<client_ip>[\d.]+) - - \[(?P<timestamp>.*?)\] "(?P<request_method>\w+) (?P<request_uri>.*?) (?P<protocol>.*?) (?P<protocol_version>.*?)" (?P<status>\d+) (?P<response_size>\d+|-) "(?P<referrer>.*?)" "(?P<user_agent>.*?)""#).unwrap();
let string = "209.160.24.63 - - [28/Mar/2023:18:22:16] \"GET /product.screen?productId=WC-SH-A02&JSESSIONID=SD0SL6FF7ADFF4953 HTTP 1.1\" 200 3878 \"http://www.google.com\" \"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.46 Safari/536.5\" 349
209.160.24.63 - - [28/Mar/2023:18:22:16] \"POST /oldlink?itemId=EST-6&JSESSIONID=SD0SL6FF7ADFF4953 HTTP 1.1\" 200 1748 \"http://www.buttercupgames.com/oldlink?itemId=EST-6\" \"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.46 Safari/536.5\" 731
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}