import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<client_ip>[\\d.]+) - - \\[(?P<timestamp>.*?)\\] \"(?P<request_method>\\w+) (?P<request_uri>.*?) (?P<protocol>.*?) (?P<protocol_version>.*?)\" (?P<status>\\d+) (?P<response_size>\\d+|-) \"(?P<referrer>.*?)\" \"(?P<user_agent>.*?)\"";
final String string = "209.160.24.63 - - [28/Mar/2023:18:22:16] \"GET /product.screen?productId=WC-SH-A02&JSESSIONID=SD0SL6FF7ADFF4953 HTTP 1.1\" 200 3878 \"http://www.google.com\" \"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.46 Safari/536.5\" 349\n"
+ "209.160.24.63 - - [28/Mar/2023:18:22:16] \"POST /oldlink?itemId=EST-6&JSESSIONID=SD0SL6FF7ADFF4953 HTTP 1.1\" 200 1748 \"http://www.buttercupgames.com/oldlink?itemId=EST-6\" \"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.46 Safari/536.5\" 731\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}