use strict;
my $str = 'My 2.2L car (L4 MUP) is a Range Rover Evoque and was registered in 2012
Who is the owner of car AB12 CDE?
S44 SHD is an example of a personalised reg plate
My password is ALL4ONE or 14ALL but my car is AL4ONE
Your Name is RAJ SOOKRAH
GHESYT5 GK66 DMO 46703h ';
my $regex = qr/\b[A-Z]{1,2}\d{1,2}\s{0,}[A-Z]{3}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}