#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[A-Z]{1,2}\d{1,2}\s{0,}[A-Z]{3}\b"
Local $sString = "My 2.2L car (L4 MUP) is a Range Rover Evoque and was registered in 2012" & @CRLF & _
"Who is the owner of car AB12 CDE?" & @CRLF & _
"S44 SHD is an example of a personalised reg plate" & @CRLF & _
"My password is ALL4ONE or 14ALL but my car is AL4ONE" & @CRLF & _
"Your Name is RAJ SOOKRAH" & @CRLF & _
"GHESYT5 GK66 DMO 46703h "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")