$re = '/^\d{2}:\d{2}:\d{2}$/m';
$str = '44:22:33';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);