package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}:\d{2}:\d{2}$`)
var str = `44:22:33`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}