$re = '/Regex2017(?!sucedido)/';
$str = 'Regex2017sucedido
Regex2017precedido';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);