using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Regex2017(?!sucedido)";
string input = @"Regex2017sucedido
Regex2017precedido";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}