import Foundation
let pattern = #"(?::.+(?=;))?(\s+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
body {
border-collapse: collapse;
border-spacing: 6px;
border:none;
font-family: Tahoma, Arial, sans-serif;
font-size: 12px;
padding: 6px;
border-bottom: 1px solid #ccc;
}
p {
color:red;
box-shadow: rgba(0, 0, 0, 0.1) 0px 4px 12px;
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)