const regex = new RegExp('(?::.+(?=;))?(\\s+)', 'gm')
const str = `body {
border-collapse: collapse;
border-spacing: 6px;
border:none;
font-family: Tahoma, Arial, sans-serif;
font-size: 12px;
padding: 6px;
border-bottom: 1px solid #ccc;
}
p {
color:red;
box-shadow: rgba(0, 0, 0, 0.1) 0px 4px 12px;
}`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);