const regex = /^(?'commodity'02)_(?'market'\w{3,})_(?'tenortype'Q)(?'offset'[1-9][0-9]?)?_(?'derivative'PHY|FUT) (?'period'Q)-(?'year'\d{4})-\b(?'month'[1-4])\b$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?\'commodity\'02)_(?\'market\'\\w{3,})_(?\'tenortype\'Q)(?\'offset\'[1-9][0-9]?)?_(?\'derivative\'PHY|FUT) (?\'period\'Q)-(?\'year\'\\d{4})-\\b(?\'month\'[1-4])\\b$', 'gm')
const str = `02_AUT_Q_PHY Q-2015-1
02_GASPOOL_H_Q_PHY Q-2015-2
02_GASPOOL_L_Q_PHY Q-2015-3
02_NBP_Q_PHY Q-2015-4
02_MGP_Q_PHY Q-2015-1
02_NCG_H_Q_PHY Q-2015-2
02_NCG_L_Q_PHY Q-2015-3
02_OTE_Q1_PHY Q-2015-4
02_POLVP_Q1_PHY Q-2015-1
02_PEGN_Q1_PHY Q-2015-2
02_SVKVP_Q1_PHY Q-2015-3
02_TTF_H_Q2_PHY Q-2015-4
02_ZEEBRUGGE_H_Q9_PHY Q-2015-1
02_ZTP_H_Q10_PHY Q-2015-2
02_ZTP_L_Q99_PHY Q-2015-3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}