import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'commodity'02)_(?'market'\\w{3,})_(?'tenortype'Q)(?'offset'[1-9][0-9]?)?_(?'derivative'PHY|FUT) (?'period'Q)-(?'year'\\d{4})-\\b(?'month'[1-4])\\b$";
final String string = "02_AUT_Q_PHY Q-2015-1\n"
+ "02_GASPOOL_H_Q_PHY Q-2015-2\n"
+ "02_GASPOOL_L_Q_PHY Q-2015-3\n"
+ "02_NBP_Q_PHY Q-2015-4\n"
+ "02_MGP_Q_PHY Q-2015-1\n"
+ "02_NCG_H_Q_PHY Q-2015-2\n"
+ "02_NCG_L_Q_PHY Q-2015-3\n"
+ "02_OTE_Q1_PHY Q-2015-4\n"
+ "02_POLVP_Q1_PHY Q-2015-1\n"
+ "02_PEGN_Q1_PHY Q-2015-2\n"
+ "02_SVKVP_Q1_PHY Q-2015-3\n"
+ "02_TTF_H_Q2_PHY Q-2015-4\n"
+ "02_ZEEBRUGGE_H_Q9_PHY Q-2015-1\n"
+ "02_ZTP_H_Q10_PHY Q-2015-2\n"
+ "02_ZTP_L_Q99_PHY Q-2015-3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}