$re = '/^[a-z]+(?:_[a-z]+)*$/m';
$str = 'welcome_to_snake_case
PASS :
snake_case
cellule
sous_cellule
a
a_a
all_good
FAIL :
/^[a-z]+(\\_[a-z]+)*$/gm
camelCase
PascalCase
kebab-case
UPPERCASE
big_sNAKe_case
snake_digita1ised_case
one_is_there^
_
___
no_trailing_dash_
_actually_neither_way
_norboth_
no_space
no_other_special-char
all_good?yes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);