using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z]+(?:_[a-z]+)*$";
string input = @"welcome_to_snake_case
PASS :
snake_case
cellule
sous_cellule
a
a_a
all_good
FAIL :
/^[a-z]+(\_[a-z]+)*$/gm
camelCase
PascalCase
kebab-case
UPPERCASE
big_sNAKe_case
snake_digita1ised_case
one_is_there^
_
___
no_trailing_dash_
_actually_neither_way
_norboth_
no_space
no_other_special-char
all_good?yes";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}