const regex = /\d{1,2}-\d{1,2}-\d{4}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,2}-\\d{1,2}-\\d{4}', '')
const str = `1-23-2018`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);