# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{1,2}-\d{1,2}-\d{4}//;t' <<< "1-23-2018"