import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[@Title]), ([^,)]+)";
final String string = "IF(SEARCH(LEFT([@Title], 3), \"CMO\") , \"Marketing\", \n"
+ "IF(SEARCH(LEFT([@Title], 3), \"CIO\") , \"IT\", \n"
+ "IF(SEARCH(LEFT([@Title], 3), \"CTO\") , \"IT\", \n"
+ "IF(SEARCH(LEFT([@Title], 3), \"CRO\") , \"Sales\", \n"
+ "IF(SEARCH(LEFT([@Title], 3), \"CPO\") , \"Product\", \n"
+ "IF(SEARCH(LEFT([@Title], 3), \"COO\") , \"Operations\", \n"
+ "IF(SEARCH(LEFT([@Title], 3), \"CFO\") , \"Finance\", \n"
+ "IF(SEARCH(LEFT([@Title], 3), \"CEO\") , \"Exective\", \n"
+ "IF(SEARCH([@Title], \"President\") , \"Exective\", \n"
+ "IF(SEARCH([@Title], \"Chairman\") , \"Exective\", \n"
+ "IF(SEARCH([@Title], \"Social\"), \"Social\" , \n"
+ "IF(SEARCH([@Title], \"Content\"), \"Content\" , \n"
+ "IF(SEARCH([@Title], \"Blog\"), \"Blog\" , \n"
+ "IF(SEARCH([@Title], \"Digital\"), \"Digital\" , ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}