use strict;
my $str = '<div class="faq__wrapper">
<div class="faq__subject faq__subject--active">
<div class="faq__header">
<h1 class="heading-light faq__title">Часті питання</h1>
</div>
<div class="nav nav_faq faq__nav">
<button class="btn-nav nav__link btn-nav--active">
<i class="icon-info icon-info_heart">
<svg>
<use xlink:href="#svg-icon-icon_heart_default"></use>
</svg>
</i>
<span>щодо проекту</span>
</button>
<button class="btn-nav nav__link">
<i class="icon-info icon-info_person">
<svg>
<use xlink:href="#svg-icon-icon_person"></use>
</svg>
</i>
<span>щодо волонтерства</span>
<?=__(\'Театр\')?>
</button>
</div>
</div>
<div class="heading-linked">
<?=__(\'Зараз у репертуарі \')?><?=$this->plural($performancesCount,
[__(\'театру\'), __(\'театру\'), __(\'театру\')])?> <br/>
<?=$performancesCount?> <?=$this->plural($performancesCount,
[__(\'вистава\'), __(\'вистави\'), __(\'вистав\')])?>
</div>';
my $regex = qr/(?<!\?)>([А-яҐґІіЇїЄє .\-!?]+)<(?!\?)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}