# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<type>[A-Z]{1})(?<subtype>[A-Z<]{1})(?<issue_country>[A-Z]{3})(?<doc_number>[A-Z0-9<]{9})(?<check_sum>[0-9]{1})(?<first_optional>[A-Z0-9<]{15})\n(?<date_brith>[0-9]{6})(?<birth_check>[0-9{1}])(?<sex>[MF]{1})(?<expiration_date>[0-9]{6})(?<expiration_check>[0-9]{1})(?<nationality>[A-Z]{3})(?<second_optional>[A-Z0-9<]{11})(?<check_digit>[0-9]{1})\n(?<lname>[A-Z]+)(?<lname2><[A-Z]+){0,}<<(?<spacing>[<]{0,})(?<fname>[A-Z]+)(?<mname1><[A-Z]+){0,}(?<complement><.+){0,}"
test_str = ("IDCHES0002068<8<<<<<<<<<<<<<<<\n"
"8102287F1301014CHE<<<<<<<<<<<4\n"
"VADIS<<QUO<<<<<<<<<<<<<<<<<<<<\n\n"
"I<NLDXI020DF236123456783<<<<<<\n"
"7208148F1108268NLD<<<<<<<<<<<9\n"
"VAN<DER<STEEN<<MARIANNE<LOUISE")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.