import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<date>(0[1-9]|[12][0-9]|3[01])[-/.](0[1-9]|1[012])[-/.]((19|20)\\d{2}))";
final String string = "this is due on 28-02-2021 at 10:00 am\n"
+ "this is due on 28/02/2021 at 10:00 am\n"
+ "this is due on 28.02.2021 at 10:00 am";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}