package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<date>(0[1-9]|[12][0-9]|3[01])[-/.](0[1-9]|1[012])[-/.]((19|20)\d{2}))`)
var str = `this is due on 28-02-2021 at 10:00 am
this is due on 28/02/2021 at 10:00 am
this is due on 28.02.2021 at 10:00 am`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}