const regex = /^(?:[^\s@]*)[\w]{1}@{1}(?:[^\s@]+)[\.]{1}(?:[^\s@]{1,255}\w{1})$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^\\s@]*)[\\w]{1}@{1}(?:[^\\s@]+)[\\.]{1}(?:[^\\s@]{1,255}\\w{1})$', 'mg')
const str = `good+alias@domain.com
good@sub.domain.com
good@domain.com
mail+alias@sub.domain.com
good.mail@domain.com
good.mail+alias@domain.com
wrong@mail.com.
wrong.mail.@domain.com
wr.ong
wr@ong
wr@@ong.com
wr@o@n.g
wrong@mail.co@m
wrong+@domain.com
wro@.ng
wrong@.
wron@g.
wrong@
wrong`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}