import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^\\s@]*)[\\w]{1}@{1}(?:[^\\s@]+)[\\.]{1}(?:[^\\s@]{1,255}\\w{1})$";
final String string = "good+alias@domain.com\n"
+ "good@sub.domain.com\n"
+ "good@domain.com\n"
+ "mail+alias@sub.domain.com\n"
+ "good.mail@domain.com\n"
+ "good.mail+alias@domain.com\n"
+ "wrong@mail.com.\n"
+ "wrong.mail.@domain.com\n"
+ "wr.ong\n"
+ "wr@ong\n"
+ "wr@@ong.com\n"
+ "wr@o@n.g\n"
+ "wrong@mail.co@m\n"
+ "wrong+@domain.com\n"
+ "wro@.ng\n"
+ "wrong@.\n"
+ "wron@g.\n"
+ "wrong@\n"
+ "wrong";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}