import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>(£[^£]+$))";
final String string = "12 12 FIESTA ZETEC 1.4i 96ps Automatic. 5dr, Ink Blue, 10K. PAS, ABS, Air Con, CD, Alloys, HFS, Electric Pack, Rear Sensors. £6,995\n"
+ "12 12 FIESTA ZETEC 1.4i 96ps Automatic. 5dr, Ink Blue, 10K. PAS, ABS, Air Con, CD, Alloys, HFS, Electric Pack, Rear Sensors. £12,995\n"
+ "12 12 FIESTA ZETEC 1.4i 96ps Automatic. 5dr, Ink Blue, 10K. PAS, ABS, Air Con, CD, Alloys, HFS, Electric Pack, Rear Sensors. £126,995\n";
final String subst = "\\t$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}