using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?>(£[^£]+$))";
string substitution = @"\t$1";
string input = @"12 12 FIESTA ZETEC 1.4i 96ps Automatic. 5dr, Ink Blue, 10K. PAS, ABS, Air Con, CD, Alloys, HFS, Electric Pack, Rear Sensors. £6,995
12 12 FIESTA ZETEC 1.4i 96ps Automatic. 5dr, Ink Blue, 10K. PAS, ABS, Air Con, CD, Alloys, HFS, Electric Pack, Rear Sensors. £12,995
12 12 FIESTA ZETEC 1.4i 96ps Automatic. 5dr, Ink Blue, 10K. PAS, ABS, Air Con, CD, Alloys, HFS, Electric Pack, Rear Sensors. £126,995
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}