$re = '/^0\s*4\s*([0-9](\s*)){8}$/';
$str = '0430066788
04124 453 23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);