package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^0\s*4\s*([0-9](\s*)){8}$`)
var str = `0430066788
04124 453 23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}