# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?<!\d)
(?:
[0-9]{4}
(?:
(?:0[1-9]|1[0-2]) (?:0[1-9]|1[0-9]|2[0-8])
|(?:0[13-9]|1[0-2]) (?:29|30)
|(?:0[13578]|1[02]) (?:31)
)
|
(?:
[0-9]{2}
(?:
0[48]
|[2468][048]
|[13579][26]
)
|(?:
0[48]
|[2468][048]
|[13579][26]
)00
)
02 (?:29)
)
(?!\d)
"""
test_str = ("aaa_20150229_bbb\n"
"aaa_2012-02-29_bbb\n"
"aaa_2000-02-29_bbb\n"
"aaa_20000229_bbb\n"
"20000228\n"
"2000-2-28\n"
"19120229\n"
"19000229\n\n\n"
"1696-2-29\n"
"16960229\n\n"
"20190228\n\n"
"aaa_1904229_bbb\n"
"aaa_18000229_bbb\n"
"aaa_17000229_bbb\n"
"aaa_16000229_bbb\n\n"
"2019-3-30\n"
"19960229\n"
"2019-02-28\n"
"20190228\n"
"20190229\n\n\n"
"aaa_20150130_bbb\n"
"aaa_20150131_bbb\n"
"aaa_2015-04-30_bbb\n"
"aaa_20150430_bbb\n"
"20190228\n"
"20190229\n"
"20200229\n"
"20000229\n"
"2000-02-29\n"
"2000-02-28\n\n"
"201911")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.