import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)\n"
+ " (?:\n"
+ " [0-9]{4}\n"
+ " (?:\n"
+ " (?:0[1-9]|1[0-2]) (?:0[1-9]|1[0-9]|2[0-8])\n"
+ " |(?:0[13-9]|1[0-2]) (?:29|30)\n"
+ " |(?:0[13578]|1[02]) (?:31)\n"
+ " )\n"
+ " |\n"
+ " (?:\n"
+ " [0-9]{2}\n"
+ " (?:\n"
+ " 0[48]\n"
+ " |[2468][048]\n"
+ " |[13579][26]\n"
+ " )\n"
+ " |(?:\n"
+ " 0[48]\n"
+ " |[2468][048]\n"
+ " |[13579][26]\n"
+ " )00\n"
+ " )\n"
+ " 02 (?:29)\n"
+ " )\n"
+ "(?!\\d)\n";
final String string = "aaa_20150229_bbb\n"
+ "aaa_2012-02-29_bbb\n"
+ "aaa_2000-02-29_bbb\n"
+ "aaa_20000229_bbb\n"
+ "20000228\n"
+ "2000-2-28\n"
+ "19120229\n"
+ "19000229\n\n\n"
+ "1696-2-29\n"
+ "16960229\n\n"
+ "20190228\n\n"
+ "aaa_1904229_bbb\n"
+ "aaa_18000229_bbb\n"
+ "aaa_17000229_bbb\n"
+ "aaa_16000229_bbb\n\n"
+ "2019-3-30\n"
+ "19960229\n"
+ "2019-02-28\n"
+ "20190228\n"
+ "20190229\n\n\n"
+ "aaa_20150130_bbb\n"
+ "aaa_20150131_bbb\n"
+ "aaa_2015-04-30_bbb\n"
+ "aaa_20150430_bbb\n"
+ "20190228\n"
+ "20190229\n"
+ "20200229\n"
+ "20000229\n"
+ "2000-02-29\n"
+ "2000-02-28\n\n"
+ "201911";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}