// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<div\s+?(.*?)\s+?(id|class)\s*?=\s*?"(.+?)"\s+(.*)\s*?>"#).unwrap();
let string = "<div style = \"border: 1px\" id = \"header\" >
<div align=\"left\" id=\"nav\" style=\"color:blue\">
<div class=\"header\" style=\"color:blue\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}