re = /<div\s+?(.*?)\s+?(id|class)\s*?=\s*?"(.+?)"\s+(.*)\s*?>/m
str = '<div style = "border: 1px" id = "header" >
<div align="left" id="nav" style="color:blue">
<div class="header" style="color:blue">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end