re = /((\!*[a-zA-Z]+)*)((\!\!)|(\!?))/
str = 'fo!o! fo!o foo! foo
fo!o!! fo!o!! foo!!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end