$re = '/((\!*[a-zA-Z]+)*)((\!\!)|(\!?))/';
$str = 'fo!o! fo!o foo! foo
fo!o!! fo!o!! foo!!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);