use strict;
my $str = '2019-12-27 13:52:38.201 INFO 1 --- [Thread-8] j.LocalContainerEntityManagerFactoryBean : Closing JPA EntityManagerFactory for persistence unit \'default\'
2019-12-27 13:52:39.535 INFO 1 --- [Thread-8] com.alibaba.druid.pool.DruidDataSource : {dataSource-1} closed
2019-12-27 13:52:39.538 INFO 1 --- [Thread-8] com.netflix.discovery.DiscoveryClient : Shutting down DiscoveryClient ...
2019-12-27 13:52:42.539 INFO 1 --- [Thread-8] com.netflix.discovery.DiscoveryClient : Unregistering ...
2019-12-27 13:52:42.540 WARN 1 --- [DiscoveryClient-0] c.netflix.discovery.TimedSupervisorTask : task supervisor shutting down, can\'t accept the task
2019-12-27 13:52:42.597 INFO 1 --- [Thread-8] com.netflix.discovery.DiscoveryClient : Completed shut down of DiscoveryClient
2019-12-27 13:52:43.329 WARN 1 --- [XNIO-1 task-15] c.n.eureka.resources.InstanceResource : Not Found (Renew): RPLUS-SERVICE-COMMUNITY - 69bce99f652f:rplus-service-community:20090
';
my $regex = qr/(\d+-\d+-\d+\s\S+)\s+(\w+)\s(\d+)\s---\s(\S+.\S+)\s(\S+\s+:)\s(\S+.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}