package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+-\d+-\d+\s\S+)\s+(\w+)\s(\d+)\s---\s(\S+.\S+)\s(\S+\s+:)\s(\S+.*)`)
var str = `2019-12-27 13:52:38.201 INFO 1 --- [Thread-8] j.LocalContainerEntityManagerFactoryBean : Closing JPA EntityManagerFactory for persistence unit 'default'
2019-12-27 13:52:39.535 INFO 1 --- [Thread-8] com.alibaba.druid.pool.DruidDataSource : {dataSource-1} closed
2019-12-27 13:52:39.538 INFO 1 --- [Thread-8] com.netflix.discovery.DiscoveryClient : Shutting down DiscoveryClient ...
2019-12-27 13:52:42.539 INFO 1 --- [Thread-8] com.netflix.discovery.DiscoveryClient : Unregistering ...
2019-12-27 13:52:42.540 WARN 1 --- [DiscoveryClient-0] c.netflix.discovery.TimedSupervisorTask : task supervisor shutting down, can't accept the task
2019-12-27 13:52:42.597 INFO 1 --- [Thread-8] com.netflix.discovery.DiscoveryClient : Completed shut down of DiscoveryClient
2019-12-27 13:52:43.329 WARN 1 --- [XNIO-1 task-15] c.n.eureka.resources.InstanceResource : Not Found (Renew): RPLUS-SERVICE-COMMUNITY - 69bce99f652f:rplus-service-community:20090
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}