import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?![azAZ]).)*$";
final String string = "123456789\n"
+ "abc123456\n"
+ "981984623\n"
+ "98198abc1\n"
+ "197197114\n"
+ "ab7189747\n"
+ "12345678a\n"
+ "A12X48967";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}