re = /who+sh/m
str = 'The fireworks went whoosh, whoooooosh, whooooooooooooooooooosh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end