package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)who+sh`)
var str = `The fireworks went whoosh, whoooooosh, whooooooooooooooooooosh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}