$re = '/^[0-9]{4}[-]{1}[0-9]{2}[-]{1}[0-9]{2}$/';
$str = '2021-01-01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);