package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[0-9]{4}[-]{1}[0-9]{2}[-]{1}[0-9]{2}$`)
var str = `2021-01-01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}