$re = '/^http[s]?:\/\/\w+(\.\w+)*(:[0-9]+)?\/?(\/[.\S]*)*$/m';
$str = 'https://localhost:8080/param/etp_fai?kaik=09&';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);