using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http[s]?:\/\/\w+(\.\w+)*(:[0-9]+)?\/?(\/[.\S]*)*$";
string input = @"https://localhost:8080/param/etp_fai?kaik=09&";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}