package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*),Microsoft-Windows-Eventlog,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)`)
var str = `Audit Success,08/08/2017 16:22:09,Microsoft-Windows-Eventlog,1100,Service shutdown,The event logging service has shut down.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}